Active TopicsActive Topics  Display List of Forum MembersMemberlist  Search The ForumSearch  HelpHelp
  RegisterRegister  LoginLogin
Nether Earth
 Brain Games Forums : Nether Earth
Subject Topic: compilation Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
coudy
Newbie
Newbie


Joined: 04 March 2009
Posts: 3
Posted: 04 March 2009 at 10:25 | IP Logged Quote coudy

Hi,
thank you for great remake. This game was my favorite on ZX.
I have downloaded source version 0.51 an 0.52, I can compile it, but game didn't start, so I downloaded your Ubuntu package version 0.53. Game start, but keys in main menu (0-5) aren't working. I can only start and play game. I can't set resolution, redefine key etc.
Can you help me ?
thank you
Back to Top View coudy's Profile Search for other posts by coudy Send Private Message Add to Buddy List
 
Jorito
Admin Group
Admin Group
Avatar

Joined: 30 December 2002
Location: Netherlands
Posts: 1930
Posted: 09 March 2009 at 20:51 | IP Logged Quote Jorito

I have sent a message to Patsie, who made the Linux binaries. Hope he will respond here soon!
Back to Top View Jorito's Profile Search for other posts by Jorito Visit Jorito's Homepage Send Private Message Add to Buddy List
 
patsie
Senior Member
Senior Member
Avatar

Joined: 08 July 2006
Posts: 257
Posted: 10 March 2009 at 10:10 | IP Logged Quote patsie

Hi Coudy,
There's a bug in the original sources which gave me a black/blank screen after starting the game, because the zoom level wasn't properly set. This can be worked around by pressing the zoom-in/zoom-out buttons (pg-up/pg-dn). I fixed this in the ubuntu/0.53 source code. (which I see now, I haven't put on my site... I'll fix that later)

From the main menu the game reads standard SDLK_<num> keys for input. I must say I can't reproduce your problem, but I do have some questions: What language keyboard are you using and are you trying the num-pad number keys, or the ones on top of the keyboard? I know that the num-pad keys won't work.

[edit]
Okay, I put the 0.53 source I used online here
[/edit]


Edited by patsie on 10 March 2009 at 10:15
Back to Top View patsie's Profile Search for other posts by patsie Visit patsie's Homepage Send Private Message Add to Buddy List
 
coudy
Newbie
Newbie


Joined: 04 March 2009
Posts: 3
Posted: 10 March 2009 at 10:14 | IP Logged Quote coudy

Hi, I'm using Slovak language, but I have installed SVK and USA keyboard. I have tried many combinations. I have tried num-pad too.
Back to Top View coudy's Profile Search for other posts by coudy Send Private Message Add to Buddy List
 
patsie
Senior Member
Senior Member
Avatar

Joined: 08 July 2006
Posts: 257
Posted: 10 March 2009 at 10:20 | IP Logged Quote patsie

Okay, Please try the source code above. If that still doesn't work, you can try editing the keys used in the mainmenu. They are in the file mainmenu.cpp at lines: 90, 94, 99, 103, 107 and 171 and look like:

if (keyboard[SDLK_0] && !old_keyboard[SDLK_0])

Just change both SDLK_0 entries with (for example) SDLK_F1 for the F1 function key.
Let us know if this works.
Back to Top View patsie's Profile Search for other posts by patsie Visit patsie's Homepage Send Private Message Add to Buddy List
 
coudy
Newbie
Newbie


Joined: 04 March 2009
Posts: 3
Posted: 10 March 2009 at 10:30 | IP Logged Quote coudy

Hi,
compiled, but numeric keys don't work. So I changed 1 to F1 in your source code, compiled and Fkeys work. Thank you

edit:
I have realized, so I have change keys in options menu too.
I will find it.

Edited by coudy on 10 March 2009 at 10:34
Back to Top View coudy's Profile Search for other posts by coudy Send Private Message Add to Buddy List
 
patsie
Senior Member
Senior Member
Avatar

Joined: 08 July 2006
Posts: 257
Posted: 10 March 2009 at 10:42 | IP Logged Quote patsie

They are in mainmenu.cpp lines 397, 399, 401,403, 405 and 407

397 scaledglprintf2(0.005,0.005,"1 - START NEW GAME   ");
399 scaledglprintf2(0.005,0.005,"2 - REDEFINE KEYBOARD");
401 scaledglprintf2(0.005,0.005,"3 - OPTIONS          ");
403 scaledglprintf2(0.005,0.005,"4 - MAP: %s",mapname);
405 scaledglprintf2(0.005,0.005,"5 - HELP");
407 scaledglprintf2(0.005,0.005,"0 - EXIT GAME        ");


[edit]
Oh, and good to hear the Function keys work
[/edit]

Edited by patsie on 10 March 2009 at 10:42
Back to Top View patsie's Profile Search for other posts by patsie Visit patsie's Homepage Send Private Message Add to Buddy List
 
Jorito
Admin Group
Admin Group
Avatar

Joined: 30 December 2002
Location: Netherlands
Posts: 1930
Posted: 10 March 2009 at 21:15 | IP Logged Quote Jorito

Hey Patsie, did you also commit your fixes to SVN?
Back to Top View Jorito's Profile Search for other posts by Jorito Visit Jorito's Homepage Send Private Message Add to Buddy List
 
patsie
Senior Member
Senior Member
Avatar

Joined: 08 July 2006
Posts: 257
Posted: 10 March 2009 at 21:47 | IP Logged Quote patsie

I did better than that. I was the one who checked in the source. So all my changes are in there.
Back to Top View patsie's Profile Search for other posts by patsie Visit patsie's Homepage Send Private Message Add to Buddy List
 
sandy85
Newbie
Newbie


Joined: 04 September 2009
Location: United States
Posts: 5
Posted: 09 September 2009 at 07:15 | IP Logged Quote sandy85

I also like this game and i enjoy to much. I am not change all.
Back to Top View sandy85's Profile Search for other posts by sandy85 Send Private Message Add to Buddy List
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic
Printable version Printable version

Forum Jump
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum

Powered by Web Wiz Forums version 7.01
Copyright ©2001-2003 Web Wiz Guide

This page was generated in 0,1406 seconds.